
1. What's New - version 2401
Changes and enhancements made to Femap for version 2401 are listed here and in the Femap readme.

Manage Femap Licensing

Licensing is updated in Femap version 2401 to seamlessly accommodate the use of different licensing
types, giving you the ability to access them in Femap without interrupting Femap (on the fly). This is
done with Femap's new Manage Femap Licensing dialog which is now the centralized location for
configuring licensing for Femap. This dialog provides a series of License Types to select from, controls to
specify the License Location information, and a Connect button to connect to the license. The Manage
Femap Licensing dialog is accessed from the main menu at Help → Manage Licensing.

With Manage Femap Licensing, you no longer need to exit Femap and execute a batch file ( go_...bat)
to switch or set a new licensing type. The Manage Femap Licensing dialog also allows you to view
available features, set your licensing to new or old legacy methods, connect to licenses, and receive
feedback on connection status (without the need to shut down and restart Femap).
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The addition of Manage Femap Licensing means there is a new workflow for Licensing. It begins when
you install Femap version 2401. You select your Licensing Type during install in the Femap installer,
which now writes the corresponding configuration data to the per-user portion of the Windows registry
(HKEY_CURRENT_USER). If you choose the Dongle or Demo licensing type, Femap starts as it did in
previous versions for the first-run. If you choose the network option, however, Femap prompts you with
the new Manage Femap Licensing dialog for the first-run.

Note:

Internally, Femap now combines all current licensing methods into a single DLL, and modularizes
Femap internal processes to access licensing API's. This removes the need for the current go_*.bat
licensing scripts used to switch licensing methods. This new capability informs a deliberate
transition by Femap to standard SALT based licensing while also facilitateting maintainability for
future phasing-out of legacy Femap licensing.

Note:

As mentioned above, Manage Femap Licensing is part of an incremental implementation of
Femap licensing improvements leading to the transition by Femap to standard SALT based
licensing. Because of this, the DEX/SSC Subscription and Bundle license types will require a restart
of Femap.

Layup Builder

A new Layup Builder dockable pane is available using the new Tools → Layup Builder command. Layup
Builder is used to interactively create a large number of Layups using an intuitive table control. Layup
Builder presents a different workflow for creating layup entities than the existing Layup Manager.

1. What's New - version 2401

1-2  Femap What's New, Femap2401
© 2024 Siemens



Where Layup Manager workflow typically allows you to create the layup, and apply the layup to a
property referenced by a specific element selection set, Layup Builder allows you to build a list of plys
and select elements, surfaces or groups where each individual ply lands on. Using the Layup Builder
table list, Femap finds the plies applied to specific elements, and builds the corresponding Layups and
properties on them to automatically update the finite element model.

Similar to other Layup commands, each Layup appears as a single row separated into columns. However,
once in Layup Builder, information about Layups can be sorted, filtered, and evaluated to help you
understand the composition and location of each ply. The Layup Builder allows you to modify certain
aspects of each ply in the table, including individual field modifications in certain columns and cells.

When the Layup Builder pane is floating, it can be repositioned and resized, just as any other floating
dockable pane. The Layup Builder can be closed by clicking the “X” on the right side of the Title bar. To
reopen the Layup Builder, select the Tools → Layup Builder command.

Layup Builder can either be used with two overall workflows. You can start with an empty table,
and build the plys individually using the controls in the table columns. Or you can import the layup
information from a Fibersim model. The Layup Builder then provides an efficient way of mapping that
data to the finite element model.

Laminates: Add Plys to Mesh

Adding plys to a specific set of elements was once a tedious task. Prior to the release of Femap version
2401, it required a multiple step process (with some redundancy involved). For instance, adding a
unidirectional ply to the top of two elements that are of two different properties and reference two
different layups. Both of those properties are referenced by other elements so you can not just modify
the existing layups. You would first need to duplicate both properties and corresponding layups, and
then reassign those newly duplicated properties to the elements we want to modify.

However, in Femap version 2401, you can now modify those layups to have the additional unidirectional
ply at the top without modifying the rest of the model. To accomplish this, Femap version 2401 has
added a new command named Add Plys to Mesh. Running this command (Model → Laminates → Add
Plys to Mesh...) opens the Add New Ply to Mesh dialog which contains controls that allow you to add a
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specific number of plies of certain material and thickness at a specified location across those previously
selected elements. The outcome of using this dialog is the new elements have an updated property and
corresponding layup with the newly added plys.

ABAQUS Analysis Manager and *STEP Import

Femap version 2401 updates the ABAQUS analysis interface to support *STEP import functionality, and
additional improvements in the Analysis Set Manager for the Abaqus solver.

ABAQUS Terminology in Analysis Set Manager
The Analysis Set Manager for the ABAQUS solver user interface is enhanced so ABAQUS
terminologies are used throughout. For instance, “Global Requests and Conditions” is changed to
"Initial Step”, and “Cases” are changed to “Steps”. The tree structure for an ABAQUS analysis will
appear considerably different from previous versions of Femap.

The "Initial Step"
As mentioned above, “Global Requests and Conditions” is changed to "Initial Step”. The Initial
Step defines the permanent Boundary Conditions (zero boundary conditions). The Boundary
Conditions dialog opening from the Initial Step has the following options activated: Constraints,
Initial Conditions, Constraint Equations, Contact Sets, and Glue Sets. These are applicable at the
beginning of the analysis, and will be applied throughout the analysis.

Note:

All the keywords and data lines related to the Initial Step are written to the model data of the
ABAQUS input file.

The Initial Step cannot be assigned a title. Step Options and Output Requests are not valid in the
Initial step. Connections of the Glue type can only be applied in the Initial Step. Once defined,
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Glue type connections stay active for the entire duration of the analysis and cannot be deactivated.
Connections of the Contact type, heowever, can be activated or deactivated in each analysis Step.

"Cases" Changed to "Steps"

The Cases node of the analysis set is changed to Step which is equivalent to the analysis step
terminology used by ABAQUS. Constraints, Loads, and Connections can be defined in each analysis
Step. The glue type connections referenced in the initial step cannot be deactivated and remain
active through all the analysis steps.

The Boundary Conditions dialog is modified for the ABAQUS solver so only ABAQUS related options
are activated. When the dialog opens from any of the analysis steps, only the following options are
activated: Constraints, Loads, and Contact Sets. These are applicable for each Step of the analysis.

*STEP Import

can The Boundary Conditions, Initial Conditions, Constraint Equations, and Connections defined in
the model data of the ABAQUS input file can now be successfully imported to Femap in the Initial
step. All *STEP related data, including the Analysis Type and related data, Boundary Conditions,
Loads, and Connections are defined in the history data of the ABAQUS input file are imported into
Femap thus creating "Steps" for each *STEP in the file.

Femap can now import all the *STEP keywords and all the subsequent keywords and data lines
defined after *STEP and before *END STEP for each *STEP of the analysis. Upon import, Femap
creates an analysis set with the Initial Step referencing the Constraints, Initial Conditions, Constraint
Equations, and Connections defined in the ABAQUS model data. Femap also creates an analysis step
for each *STEP keyword in the ABAQUS input file. In cnclusion, Femap imports the following for
each parse of *STEP: Analysis procedure/ type, Boundary Conditions, Loads, Output Requests, and
Activated/Deactivated status of Connections.

Migration of Femap Models Created in Earlier Versions

Femap 2401 is capable of importing older Femap models without changing the meaning of the
input file generated by Femap version 2401 and previous versions.

Sloshing Analysis

Femap version 2401 includes extended support for dynamic analysis with incompressible fluids. This
type of analysis is typically used to simulate fluid filled tanks. The dynamic behavior of fluid filled tanks
is different from the unwetted structure, due to the effect of the fluid on the structure. Previous versions
of Femap included support for modeling the incompressible fluids as a virtual fluid mass using boundary
element techniques (i.e. the “Virtual Fluid Mass” method). Femap version 2401 now includes support for
modeling the incompressible fluid explicitly as a defined fluid mass with finite elements (i.e. the “Defined
Fluid Mass” method). This capability allows you to compute the elastic modes of the containing structure
while accounting for the Sloshing of a fluid free surface, which cannot be done with the current Virtual
Fluid Mass method.

Sloshing Analysis
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Note:

For detailed information about the Defined Fluid Mass method, see the Dynamic Analysis with
Incompressible Fluids section of the Simcenter Nastran Advanced Dynamic Analysis User's
Guide.

Femap Fluid Regions

Support for the Defined Fluid Mass method is added in Femap v2401. Existing interfaces for defining
fluid regions are updated, and new Analysis Set Manager interfaces are added to fully support the
Defined Fluid Mass capabilities.

As stated, the Defined Fluid Mass method uses finite elements to model the incompressible fluid
volume. Unlike with the Virtual Fluid Mass method, you MUST create a finite element representation
for each incompressible fluid volume.

There are restrictions when modeling fluid volume:

• The fluid volume must be modeled using solid elements connected by fluid nodes which are
distinct from the nodes on the structural mesh. To do this, you will need to use the Modify →
Update Other → Node Type command to update the nodes connecting the fluid elements to a
Fluid Point.

• To define the Free Surface of the fluid, you will still need to create a Fluid Region with the
Connect → Fluid Region command. The Fluid Region dialog is updated with Incompressible
Fluid Surface options (maps to the INCMPFL bulk data entry in Simcenter Nastran) that allow
you to specify which fluid mass method to use.

Note:

The definition of the fluid region changes based on the method that you are in. For Virtual
Fluid, you define the wetted faces of plate elements. For Incompressible Fluid Surface, you
will instead select the faces of the solid elements in the fluid volume mesh that comprise
the free surface. For this reason, when you switch types on the fly, you are prompted to
reset the region.

Analysis Set Manager

Applicable Analysis Types for the new Incompressible Fluid functionality are SOL 103 Real
Eigenvalues, and SOL 111 Modal Frequency Response. In the Femap interface, these would
be Normal Modes/Eigenvalue and Frequency/Harmonic Response with the solution type set to
modal. Within the Options branch of the Analysis Set, a new Incompressible Fluid Options
root is available. This is the single place in the Analysis Set Manager to configure your dynamic
analysis with Incompressible Fluid options, fluid-structure interaction modeling parameters, and
fluid-structure interaction control parameters.

Output

There is some important information to note regarding output for a dynamic analysis with
incompressible fluids using the Defined Fluid Mass method. When you analyze your model, a
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message may appear in the messages window stating "Warning: Running analysis with defined
fluid mass method. After solver has finished running, import internally generated PLOTEL mesh data
from MODEL-000_PLOTEL.dat".

You receive this warning because Simcenter Nastran internally creates 2D plot-only elements for the
slosh surface. In Femap, the corresponding bulk data entries are placed in a separate DAT file named
with original filename concatenated with “_PLOTEL”. To post-process with this slosh surface, the you
must use the File → Import → Analysis Model command to bring these elements into Femap as
plot-only elements. Only then, you will be able to post-process with them.

Updates to Simcenter Nastran Solvers

Solution 401 NLCNTL Strategy Parameters Update

The Strategy Parameters (NLCNTL) dialog used when running multi-step structural analysis in
Simcenter Nastran, SOL 401 is updated to be a tabbed dialog. This enhancement improves the user
experience by re-organizing all the available parameters on several separate dialogs into a single,
more intuitive tabbed dialog.

Also, to support newly added Strategy Parameters, two new API calls for the AnalysisCase and
AnalysisMgr Object Properties have been added to the Femap API:

• REAL8 NasMsnlCntRTOLB - Used to programmatically set a value for the Incremental Rotation
Limit in Iteration (RTOLB) Time Control strategy parameters (real numbers > 0.0, default 20).

• BOOL NasMsnlCntSTKFRST - Controls whether Femap includes Stress Stiffening at the first
time step. If set to "Yes", the Include Stress Stiffeneing at First Iteration (STKFRST) Stiffness
Parameter is activated.

Command Finder

Femap adds Help results, an Online Search option, results from Femap toolboxes and toolbars, more FEA
related "keywords" and keyboard shortcuts (when applicable) to the Command Finder (accessed via the
Search Commands field found in menu bar to the right of Help menu). Type keyword(s) into the field,
and available Commands/Help containing the keyword(s) are listed after clicking the magnifying glass in
the field or pressing Enter on the keyboard.

Generally, clicking on a result starts the command. Also, included in each result, is the name of the
command, its menu location, a ? mark icon to open the relevant help topic, and a hyperlink to open a
web browser search for the entered search text.

Updates to Simcenter Nastran Solvers
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API

New and updated API Objects and Attributes

• Added bClear, nShowSetID, and nHideSetID to the feView object to set the group ids in Set
Objects used in the current view for Multi Group Display.

New and Updated API Methods

• Added SetMultiGroupListFromSets method to the feView object.

New and Updated Properties

• Added REAL8 NasMsnlCntRTOLB and BOOL NasMsnlCntSTKFRST properties to AnalysisCase
and AnalysisMgr objects.
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